IT Status Announcements

Issue with Canvas security certificate
Incident Report for uchicago
Resolved
The vendor has resolved the issue with the Canvas security certificate. The security notifications should no longer appear when you visit canvas.uchicago.edu. If you are still experiencing the security notice, try clearing your browser's cache and restarting. If the problem persists, please contact us at canvas@uchicago.edu or contact the ITS Service Desk at 2-5800.
Posted May 25, 2017 - 17:53 CDT
Investigating
There is currently an issue with the Canvas security certificate. When users try to log in to Canvas they will receive a message saying that the connection is not secure or that the site identity cannot be verified. Users can allow the connection or click continue to get past the message and log in to Canvas; the certificate itself is still valid. We are currently working on the issue with our vendor, and we apologize for any inconvenience this may cause you.
Posted May 25, 2017 - 17:36 CDT
This incident affected: Canvas Learning Management System.