Box reports that their services have fully recovered, but they are still monitoring for possible issues.
Posted Jun 12, 2025 - 16:33 CDT
Update
Google has begun mitigating the issues in Google Cloud (https://status.cloud.google.com/), and Box Services have begun to recover. Box continues to be actively engaged in working with Google to ensure a prompt recovery.
Posted Jun 12, 2025 - 15:36 CDT
Identified
Box has identified that the issue is due to an ongoing set of Google cloud (https://status.cloud.google.com/) issues, Box services like Notes, Uploads and Downloads are seeing significant impact. Box is actively engaged with their Cloud service provider and are partnering with them to prioritize recovery of services, In parallel, Box continues investigating all means possible to provide a prompt recovery of services.
Posted Jun 12, 2025 - 14:14 CDT
Investigating
Starting at approximately 1:20PM CST, Box users may be seeing issues with Uploads/Downloads and slowness when opening and editing their files and Box Notes. Box is actively investigating this issue - please see https://status.box.com/ for the latest updates.
Posted Jun 12, 2025 - 14:05 CDT
This incident affected: UChicagoBox (Box Notes - Web Application, Box Web Application - Uploads/Downloads).