IT Status Announcements

Workday Unavailable

Incident Report for uchicago

Resolved

As of 3 p.m.., Workday is back up and working normally.
Posted Mar 17, 2025 - 15:09 CDT

Investigating

Workday is currently unavailable. The vendor is aware of the issue and is looking into the problem.
Posted Mar 17, 2025 - 14:19 CDT
This incident affected: Administrative Applications (Human Resources Systems).