As of 2:30 p.m., email is working normally, and all locally delayed email has been delivered. Email from external sources may still be delayed at those sources, but should be delivered within the next few hours.
Posted Jul 14, 2025 - 14:35 CDT
Monitoring
As of 2 p.m., new email is being delivered promptly, and the queue of deferred email is in the process of delivery. IT Services will continue to monitor the situation until all of the queued email has been delivered.
Posted Jul 14, 2025 - 14:25 CDT
Investigating
At approximately 1 p.m. the issue became worse. At this point, incoming email from multiple non-uchicago.edu sources is being delayed. IT Services continues to work with the vendor for resolution.
Posted Jul 14, 2025 - 13:40 CDT
Update
As of 12:30 p.m., some uchicago email is still being deferred. The vendor continues to work on the problem.
Posted Jul 14, 2025 - 12:40 CDT
Identified
As of 11:30 a.m., the vendor has installed fixes which seem to be working -- deferred email from earlier this morning is being delivered. However, some new messages are still being delayed.
Posted Jul 14, 2025 - 11:29 CDT
Investigating
Some email messages being sent from Microsoft 365 to destinations outside Microsoft 365 are being delayed. This includes email being sent to @lists.uchicago.edu and other outbound email. IT Services is working with the vendor to resolve this situation.