IT Status Announcements

RightFax Email Issue

Incident Report for uchicago

Resolved

As of 9:00 a.m. RightFax is running normally and working through the backlog of faxes and notifications. The source of the issue, a corrupt outbound FAX, has been removed.
Posted Jun 06, 2025 - 09:43 CDT

Investigating

The RightFax electronic fax service is currently experiencing a service interruption.  Email to/from the RightFax service is being held and not sent onward to the intended recipients. IT Services staff are working to resolve the problem.
Posted Jun 06, 2025 - 08:00 CDT
This incident affected: Telephones & Call Centers.